A Poem

I have no idea where this Poem originates from, but it has made a signifiant impression on a close family member. I share it here in the hope someone else stumbles across it someday.


We met and married a long time ago
We worked long hours when wages were low
No telly, no wireless, no bath, for times were hard
Just cold water tap and a walk up the yard
No holidays abroad, no carpets on floors
We put coal on the fire and never locked doors
Our children arrived to fill in those days
We bought them up without any state aid
They were quite safe to play in the park
And the old folk could go for a walk in the dark
No valium, no drugs, no LSD
We cured most our ills with a good cup of tea
If you were sick you were treated at once
No fill in the forms and come back in 6 months
No vandals, no mugging, there was nothing to rob
We felt rich with a couple of bob
People seemed happier in those far off days
Kinder and caring in so many ways
Milkmen and paperboys would whistle and sing
A night at the pictures was quite a mad fling
We all had our share of troubles and strife
We just had to face it that’s the pattern of life
But now I’m alone I look back through the years
I don’t think of the badtimes the trouble and tears
I remember the blessings, our home and the love
And that we shared together
I thank god above

RIP Nan.

Ubuntu Server + Xubuntu-core

Simple HowTo for adding a graphical display to a base Ubuntu Server 20.04 system.

user@ubuntu:~$ sudo apt update && apt upgrade -y
user@ubuntu:~$ sudo apt install lightdm tasksel
user@ubuntu:~$ sudo tasksel install xubuntu-core
user@ubuntu:~$ reboot

When the system has rebooted you will be able to log into the xubuntu desktop. The -core indicates just the core desktop environment rather than the numerous recommended / associated apps.

Other desktops are just as easy, want mate, then its ubuntu-mate-core. Lubuntu is lubuntu-core. You get the idea.

ArubaOS-CX, OSPFv2 Configuration

OSPF configuration is simple on Aruba, with a few simple differences between OS-CX and Cisco’s approach. Once both configured though, the two vendors equipment works very well, just as expected.

For clarity, to confirm the current OSPF state we can check to see if it is running. I’ve checked both the Default VRF and the FWTEST VRF whose configuration is explained here.

ArubaOS-CX# sh ip ospf
OSPF Process is not running on VRF default.
ArubaOS-CX# sh ip ospf vrf FWTEST
OSPF Process is not running on VRF FWTEST.
ArubaOS-CX# 

Initially in this example we will configure OSPFv2 to run in the FWTEST VRF, whilst leaving the Default VRF as it is. To start the process, we need to define OSPF

ArubaOS-CX# 
ArubaOS-CX# conf t
ArubaOS-CX(config)# router ospf 
  <1-63>  Specify the OSPF Process ID 
ArubaOS-CX(config)# router ospf 39 
  vrf   VRF Instance. 
  <cr>  
ArubaOS-CX(config)# router ospf 39 vrf FWTEST
ArubaOS-CX(config-ospf-39)# router ospf 39 vrf FWTEST

Much like the Cisco CLI, you can use the ? to show command help as appropriate. Here for example, we can see that Aruba use 6-bits to store the process ID. The process ID is only locally significant and good practise would be to use different process ID’s for each VRF. In testing though ArubaOS-CX does appear to allow you to use the same number for default and another VRF. I was surprised that it didn’t seem to break anything, but going forward I will use separate IDs. Here I chose 39 and specified which VRF it applied to.

We then go on to specify a router-id and other operating behaviours we need.

ArubaOS-CX(config-ospf-39)# 
ArubaOS-CX(config-ospf-39)# router-id 192.168.40.30
ArubaOS-CX(config-ospf-39)# reference-bandwidth 40000
ArubaOS-CX(config-ospf-39)# passive-interface default
ArubaOS-CX(config-ospf-39)# redistribute connected
ArubaOS-CX(config-ospf-39)# area 0.0.0.40
ArubaOS-CX(config-ospf-39)# 

At this stage, we do not have any ospf interfaces attached to the vhf FWTEST.

ArubaOS-CX# sh ip ospf vrf FWTEST
Routing Process 39 with ID : 192.168.40.30 VRF FWTEST
------------------------------------------------------


OSPFv2 Protocol is enabled
Graceful-restart is configured
Restart Interval: 120, State: inactive
Last Graceful Restart Exit Status: none
SPF: Start Time: 200ms, Hold Time: 1000ms, Max Wait Time: 5000ms
Maximum Paths to Destination: 4
Number of external LSAs 0, checksum sum 0
Number of areas is 1, 1 normal, 0 stub, 0 NSSA
Number of active areas is 0, 0 normal, 0 stub, 0 NSSA
BFD is disabled
Reference Bandwidth: 40000 Mbps
Area (0.0.0.40) (Inactive)
  Interfaces in this Area: 0 Active Interfaces: 0 
  Passive Interfaces: 0 Loopback Interfaces: 0 
  SPF calculation has run 1 times
  Area ranges: 
  Number of LSAs: 0, checksum sum 0 


ArubaOS-CX#
ArubaOS-CX# sh ip ospf interface vrf FWTEST
OSPF Interface is not attached to VRF FWTEST.
ArubaOS-CX# 

So next we need to attach at least one interface, the area were are attaching to is already defined above, if it isn’t defined you will get an error.

ArubaOS-CX# conf t
ArubaOS-CX(config)# interface vlan999 
ArubaOS-CX(config-if-vlan)#                             
           config-if-vlan)# ip ospf 39 area 0.0.0.40                         
ArubaOS-CX(config-if-vlan)# no ip ospf passive              
ArubaOS-CX(config-if-vlan)# 

For a basic configuration that the config that’s required. We are not running VRF-lite, with a Cisco 4500 as a neighbour. We can see from our routing table all is well.

ArubaOS-CX# sh ip ro vrf FWTEST


Displaying ipv4 routes selected for forwarding


'[x/y]' denotes [distance/metric]


0.0.0.0/0, vrf FWTEST 
        via  172.31.255.129,  [110/114],  ospf
172.31.255.240/28, vrf FWTEST 
        via  vlan998,  [0/0],  connected
172.31.255.192/28, vrf FWTEST 
        via  loopback99,  [0/0],  connected
172.31.255.128/28, vrf FWTEST 
        via  vlan999,  [0/0],  connected
172.31.255.4/30, vrf FWTEST 
        via  172.31.255.129,  [110/64],  ospf
172.31.255.12/30, vrf FWTEST 
        via  172.31.255.129,  [110/44],  ospf
172.31.255.8/30, vrf FWTEST 
        via  172.31.255.129,  [110/54],  ospf
172.31.255.0/30, vrf FWTEST 
        via  172.31.255.129,  [110/84],  ospf
172.31.255.130/32, vrf FWTEST 
        via  vlan999,  [0/0],  local
172.31.255.193/32, vrf FWTEST 
        via  loopback99,  [0/0],  local
172.31.255.241/32, vrf FWTEST 
        via  vlan998,  [0/0],  local


ArubaOS-CX#  

As you would expect for a standards based protocol, it just works !

Finally just for reference, this was all done on an 6300 running AribaOS-CX FL.10.04.0030

ArubaOS-CX, VRF Configuration

Adding the basics of a VRF configuration to an ArubaOS-CX is both simple, and very similar to other vendors platforms. In the example below we are adding a VRF called FWTEST and assigning two SVI’s to it along with a Loopback.

First we can see what VRFs are already configured, in this case none:

ArubaOS-CX# show vrf
VRF Configuration:
------------------
VRF Name   : default
        Interfaces             Status
        -----------------------------
        vlan1                    up
        vlan254                  up

ArubaOS-CX#

Then define the VRF, including the route distinguisher.

ArubaOS-CX# conf t
ArubaOS-CX(config)# vrf FWTEST
ArubaOS-CX(config-vrf)# rd 10:39
ArubaOS-CX(config-vrf)#

Ensure that any VLANs that require SVI’s in the new VRF are defined. If not we need to create them.

ArubaOS-CX(config-vrf)# vlan 998
ArubaOS-CX(config-vlan-998)# name FWTEST_Clients
ArubaOS-CX(config-vlan-998)# vlan 999
ArubaOS-CX(config-vlan-999)# name FWTEST_L3
ArubaOS-CX(config-vlan-999)# 

Configure the required SVIs and any other layer 3 interfaces, in our case Loopback 99.

ArubaOS-CX(config)# # interface vlan998
ArubaOS-CX(config-if-vlan)# vrf attach FWTEST
ArubaOS-CX(config-if-vlan)# ip address 172.31.255.241/28
ArubaOS-CX(config-if-vlan)# 
ArubaOS-CX(config-if-vlan)# interface vlan999
ArubaOS-CX(config-if-vlan)# vrf attach FWTEST
ArubaOS-CX(config-if-vlan)# ip address 172.31.255.130/28
ArubaOS-CX(config-if-vlan)# 
ArubaOS-CX(config-if-vlan)# interface loopback 99
ArubaOS-CX(config-loopback-if)# vrf attach FWTEST
ArubaOS-CX(config-loopback-if)# ip address 172.31.255.193/28
ArubaOS-CX(config-loopback-if)# 

Now if we check the VRFs on the switch, we can see our new SVIs and the Lo99 are all attached to the VRF FWTEST.

 
ArubaOS-CX# show vrf
VRF Configuration:
------------------
VRF Name   : default
        Interfaces             Status
        -----------------------------
        vlan1                    up
        vlan254                  up


VRF Name   : FWTEST
        Interfaces             Status
        -----------------------------
        loopback99               up
        vlan998                  up
        vlan999                  up


ArubaOS-CX# 

Finally, we can check the FWTEST routing table. This shows us the routes for the attached networks we have just defined. No other routes are shown as we are not going any routing with other devices yet.

ArubaOS-CX# 
ArubaOS-CX# sh ip ro vrf FWTEST

Displaying ipv4 routes selected for forwarding

'[x/y]' denotes [distance/metric]

172.31.255.240/28, vrf FWTEST 
        via  vlan998,  [0/0],  connected
172.31.255.192/28, vrf FWTEST 
        via  loopback99,  [0/0],  connected
172.31.255.128/28, vrf FWTEST 
        via  vlan999,  [0/0],  connected
172.31.255.130/32, vrf FWTEST 
        via  vlan999,  [0/0],  local
172.31.255.193/32, vrf FWTEST 
        via  loopback99,  [0/0],  local
172.31.255.241/32, vrf FWTEST 
        via  vlan998,  [0/0],  local

ArubaOS-CX# 

Next we can go on to configure OSPF

Finally just for reference, this was all done on an 6300 running AribaOS-CX FL.10.04.0030